Amsterdam GTT Datacenter Outage

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 12:37 CET

Investigating

The Amsterdam GTT datacenter is currently impacted by network issues, first observed at 11:20 CET. The Thales Incident Response Team is actively working to identify the root cause and restore normal operations. Further updates will be communicated as the situation develops.
Posted Mar 23, 2026 - 12:10 CET
This incident affected: EU Service Zone.