Investigating issues with RITM component

Postmortem

Posted Feb 12, 2026 - 14:56 CET

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 11:40 CET

Investigating

The Thales Incident Response Team is actively investigating reports of a potential service interruption with RITM services.

We apologize for any inconvenience and will update this incident with additional information as it becomes available.
Posted Dec 09, 2025 - 11:37 CET
This incident affected: EU Service Zone.