Cloud WAF Ongoing Incident

Resolved

We will now close this incident.
Posted May 21, 2026 - 20:51 UTC

Update

The affected customers have been returned to operational status; however, the WAF is still experiencing issues. We will keep this incident open until we get confirmation that all issues have been resolved.
Posted May 21, 2026 - 12:49 UTC

Investigating

Our Cloud Web Application Firewall is experiencing issues affecting a small subset of customers. Updates regarding the progress of the incident can be found here:

https://status.imperva.com/incidents/yhpxj3h2fc3g?_sm_au_=iVV67Nr3fDc3DKfQ

Thank you.
Posted May 20, 2026 - 22:27 UTC
This incident affected: EU Service Zone.